AWS Connectivity Advisory EU

Incident Report for TeleTracking EU

Resolved

AWS has indicated improved stability in the EU region, and TeleTracking services remain stable with no reported customer impact. This incident is considered resolved. We will continue routine monitoring.
Posted Apr 27, 2026 - 16:43 UTC

Monitoring

We are monitoring TeleTracking services in the EU region following an advisory from AWS regarding intermittent connectivity. No customer impact has been reported. We will continue to observe service behavior and monitor the related AWS issue.
Posted Apr 27, 2026 - 16:28 UTC

Investigating

We are investigating a potential issue after AWS notified us of intermittent connectivity issues in the EU region. At this time, no customer impact has been reported. We are monitoring the situation closely.
Posted Apr 27, 2026 - 16:17 UTC
This incident affected: Overall Platform.